Timeline for Is it poor technique to have functions within a class depend on one another in a "cascade" type fashion?
Current License: CC BY-SA 3.0
7 events
when toggle format | what | by | license | comment | |
---|---|---|---|---|---|
Oct 23, 2011 at 3:02 | answer | added | ubtng | timeline score: 2 | |
Oct 21, 2011 at 15:50 | vote | accept | LookingForHelpWithArray | ||
Oct 21, 2011 at 15:50 | comment | added | LookingForHelpWithArray | @ThomasClayson - I will work on improving the code in the way you suggested and posting it at codereview | |
Oct 21, 2011 at 15:08 | comment | added | Thomas Clayson |
For example: getSearchResults() runs the function getFetchURL() which just sets variables. This is a bit OTT and actually makes the code less readable and maintainable (again IMO) because I'm having to constantly scroll through your code to work out what you're doing and what's happening on EVERY line.
|
|
Oct 21, 2011 at 15:06 | comment | added | Thomas Clayson |
You're being a little bit too verbose IMO. You've got a lot of functions which get and set variables which aren't necessary. You can set variables like this: public $baseSearchURL = 'http://url.com'; Or you could set them all in the __construct() function. That removes the need for a setter and a getter for that variable. Also, every time you run setSearchURL() you're also setting the $baseSearchURL variable, even though its the same string. If you take this out then it means you only set it once. Make your code more readable - but don't go OTT.
|
|
Oct 21, 2011 at 14:47 | answer | added | ChrisF♦ | timeline score: 6 | |
Oct 21, 2011 at 14:40 | history | asked | LookingForHelpWithArray | CC BY-SA 3.0 |