9 events
when toggle format what by license comment
Jun 15, 2019 at 23:41 comment added gnasher729 Much less readable. The variable name is horrible (BothCostsAreValid would be better. There is nothing here about products). But even that doesn't add anything to the readability, because just checking CostIn, CostOut is fine. You'd introduce an extra variable with a meaningful name if the meaning of the expression that is being tested is not obvious.
Jan 10, 2017 at 20:37 comment added Miles Rout That's silly. if (CostIn <= 0 || CostOut <= 0) is completely fine.
Jan 6, 2017 at 17:05 comment added danny117 Your on the right track.
Jan 6, 2017 at 16:06 comment added Hagen von Eitzen Of course, costs can be zero (think Xmas presents). And in times of negative interest rates negative costs should not be too surprising either and at least the code should be prepared to deal with it (and be it by throwing errors)
S Jan 5, 2017 at 21:38 history suggested Captain Man CC BY-SA 3.0
Remove chattiness and add in-line code formatting
Jan 5, 2017 at 20:04 review Suggested edits
S Jan 5, 2017 at 21:38
S Jan 5, 2017 at 18:07 history suggested CommunityBot CC BY-SA 3.0
Change git style markdown to SE style markdown
Jan 5, 2017 at 17:42 review Suggested edits
S Jan 5, 2017 at 18:07
Jan 5, 2017 at 17:19 history answered user949300 CC BY-SA 3.0