What is the most concise (yet descriptive) way of naming a subclass that only add a specific minor thing to the parent? I encountered this case a lot in WPF, where sometime I have to add a small functionality to an out-of-the-box control for specific cases.
Example: TreeView doesn't change the SelectedItem on right-click, but I have to make one that does in my application.
Some possible names are
TreeViewThatChangesSelectedItemOnRightClick(way too wordy and maybe difficult to read because there is so many words concantenated together)
TreeView_SelectedItemChangesOnRightClick(slightly more readable, but still too wordy and the underscore also breaks the normal convention for class names)
ExtendedTreeView(more concise, but doesn't describe what it is doing. Besides, I already found a class called this in the library, that I don't want to use/modify in my application).
MyTreeView, etc. (doesn't describe what it is doing).
It seems that I can't find a name which sounds right. What do you do in situation like this?