The consensus seems to be that one should follow the convention of the platform they're developing for. See:
Naming conventions: camelCase versus underscore_case?
However, PHP doesn't seem to strictly follow any convention internally (no surprises there), even for methods and functions (e.g. mysqli::set_local_infile_default
,
PDOStatement::debugDumpParams
); however, underscores seem to be dominant in function names.
However, what I couldn't find was this: what's the dominant naming convention for variables in PHP?