I am struggling with naming convetions in C# I do not know when to use PascalCase or camelCase. I have read Microsoft's naming convention, but I got lost ther http://msdn.microsoft.com/en-us/library/ms229045(v=vs.110).aspx
As far as I know this is correct:
public int Number; private int number; public void Method(); private void method(); int number;//for any local variable
But in context of that above how should I name components in XAML:
x:Name="button". They seems to be private field so I should use camelCase, but on the other hand everywhere on the examples I see PascalCase for
I do not ask about one's habits, but orthodoxic/official/C# guru style.