I'm writing some software for an embedded system. I am trying to think of clear names for my single pin output functions.
Normally, when I'm working with active-high outputs (ON = 1, OFF = 0), I am happy to call these functions "setX" and "resetX", where X is a more descriptive name for the output that I'm working with. However, some of my outputs are active-low (ON = 0, OFF = 1), and it seems bizarre to make my "setX" make the output 0.
Is there a standard naming convention for (re)setting values that are on when they're 0?