In OOP coding, there is a long standing naming convention to name accessor/mutator methods
setThing. These directly manipulate the properties, which are often private.
Should these naming conventions be 'reserved' solely for manipulating the object properties? or can they be used in other methods -
readFileContents is much clearer as it implies the objects property in this case isn't being accessed, but rather a files contents are being read. However, it is a little ambiguous in that it doesn't imply the results are being returned like