Intuitively, I know that (in terms of a maintainable, understandable codebase) the following code is bad practice
var foo = fooFunc(barFunc(),wooFunc(chewFunc()));
and might be better stated as
var bar = barFunc(); var chew = chewFunc(); var woo = wooFunc(chew); var foo = fooFunc(bar, woo);
This makes debugging easier, code more readable etc. etc...
Instead of personally spelling this out to co-developers, it might be better to lead them to an existing page that explains the perils of such a construct.
Is there an official term for this kind of anti-pattern?