At work, we are having 'arguments' about naming styles / conventions. Imagine having a service called
UserSettingsService. This has 2 methods, one to get the user settings and one to save. Would you name the method to include what it does exactly, like
.getUserSettings(), or just
One argument is that the
UserSettings part is implied in the service name. The other argument is that a full method name of
getUserSettings() is unambiguos. Is there any 'correct' way to do this?