This type of naming scheme reminds me of a physics class or a math class. I really recommend you refrain from using naming conventions from other fields as most fields focus far more on truncation than readability.
I would suggest sticking to normal conventions unless you are absolutely certain that people reading it will be able to understand the intention. For instance, in the case of generic programming, people will often use a single capital letter. In your case however, I do not believe people reading it would be able to determine your intention.
Think of it this way. I don't know what the intention of those vectors are as an outsider, and that's a problem. I should be able to immediately know the purpose of those variables, or have a good idea by simply reading the names.
If you think for a bit I'm sure you can come up with a more suitable name like textureCoordinates (if this is indeed what you are trying to implement). Otherwise you're going to have to leave comments giving a short description of what your variable is used for, which can be quite annoying for those who may have to keep going back to it.