-1

So I am writing a method to check and throw if a new transaction is being made in another transaction. I first came up with straight forward checkNestedTransaction, but this seems vague since I cannot see what this method actually do.(like, when does this method throw)

What would be the preferred name for this method?

I've considered following:

  • checkNestedTransaction
  • requireNoTransaction
-1

I decided to use requireExclusiveTransaction for now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.