I am reading on Coding Complete book the following statement:
To name a procedure, use a strong verb followed by an object A procedure with functional cohesion usually performs an operation on an object. The name should reflect what the procedure does, and an operation on an object implies a verb-plusobject name. PrintDocument(), CalcMonthlyRevenues(), CheckOrderlnfo(), and RepaginateDocument() are samples of good procedure names.
In my code I apply this principle but some routines have an adjective in front the noun example:
Currently I am using
_getFirstView() _getLastView() _getActiveView() _getActiveMasterView()
I am wondering if this naming could be improved for example using the following variant (in some how how found them more visually organized)
_getViewFirst() _getViewLast() _getViewActive() _getViewMasterActive() ...
What is a good practice which makes sense in this scenario?