There is a need to separate services working with data into two groups: ones that perform read-only operations and others doing Create(or Add) + Update(can also be called Modify) + Delete(Remove). First one will be (obviously) named ReadDataService or ReadOnlyDataService. What about second one? I'm looking for a common name for service that performs CUD. UpdateDataService comes first into the mind, but it does not completely reflect its content. ModifyDataService or WriteDataService (as opposed to Read) can also work, but maybe there are even better options out there?

  • 1
    One service is for Writing. The other is for Reading. Another moniker is Command vs Query. Commented Jun 14, 2017 at 21:20
  • Edit can be possible verb for describing these operations.
    – apdevelop
    Commented Dec 3, 2019 at 7:35

1 Answer 1


Firstly, ReadDataService and ReadOnlyDataService are the same. Both are reading, you don't do anything special to the data in either instance. So i probably wouldn't even split those up.

In regards to the rest of the question, honestly Update works just fine. It has the same meaning as Modify, which is altering something which already exists. Update works fine, because your bringing data up-to-date with the most recent information you have.

On the whole, CRUD (Create, Read, Update, Delete) all work just fine as descriptors for functions. They define exactly what is being done to data, and can be used as names easily.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.