-2

I hosted a hobby NodeJS Server from my Linux and all is fine by accessing my direct IP.

Because I find this ugly and also less secure, I decided to route my domain which is set to Cloudflare to my IP. Then as I access the URL, I was prompted with an Authentication that I had never set up.

The question is, why proxy-ing through Cloudflare causes this? And how to fix this?

EDIT: I seem to find out the reason. It seems that my server is prompting Authentication whenever the port is not specified. Means Cloudflare is trying to redirect to my IP without the port. But would still need to know the best practice in this scenario and how to solve it.

EDIT2: I solved this by moving my port to 80. Since that is by default. But would pretty much still want to know if it is possible to get other ports to work.

closed as off-topic by gnat, amon, 8bittree, Jörg W Mittag, Erdrik Ironrose Feb 12 '18 at 14:47

  • This question does not appear to be about software engineering within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    I'm voting to close this question as off-topic because it is about using some tool or service (here: CloudFlare). Such questions are on topic only if they cover how the tool integrates into some development process – after all, this site is about Software Engineering. See our help center for details. Please read: Where does my tool question go? Usage of development tools is on topic on Stack Overflow. For general purpose tools go to Super User. – amon Feb 8 '18 at 8:26
0

you can disable the Cloudflare proxy service (cloud icon in the DNS configuration)

so Cloudflare will only work as a dns provider and not modify the traffic to your server.

Not the answer you're looking for? Browse other questions tagged or ask your own question.