I've been writing some code comments, and I've been trying to refer to the index integer of a enum type, but I'm not sure what it's called. I'm tempted to call it the identifier, however there is likely a word that already exists.
It's hopefully easier to see what I mean with a example.
enum Weekday
{
Monday,
Tuesday,
Wednesday,
Thursday,
Friday
}
/// <summary>
/// A test method
/// </summary>
/// <param name="weekdayId">The ... for the enum weekday</param>
void test(int weekdayId)
{
}
I'm leaning towards identifier, as that seems to fit with my comment, but I just wanted to check first that there wasn't a word already. If not I think it should be called the gloopdedoop.