I am struggling with naming 3 variables defining the following concept:
An action, after being performed, is not available for an amount of time and then is available again.
The concept comprises 3 variables: - A boolean (is action available?) - An int (action 'cooldown' duration) - Another int (action 'cooldown' countdown/timer)
As you can imagine, naming them
actionCooldownCountdown is awkward, as the names are too long.
I can't, however, find a better naming standard for this concept.
I thought about delay and pause but they don't necessarily communicate "period of unavailability after use".
The context is a bit generic, this is in game development but I am using these cooldowns anywhere from input to movement to collisions.