I have proposed a REST API called 'getSessionState' which basically a backend API that retrieves some state info from a redis server and return to the clients.
Because the state data is kept in a Redis server, whenever a user calls the function I will extend the expiry of the redis data structure by a bit in order to avoid key miss.
A question is raised by one of my colleagues that strictly speaking it is making a change to the state. So it shouldn't be called 'getSessionState' because 'get' implies no change to the backing data.
Is it a fair comment?
If so, what will be good alternative name to
My team generally uses Google's API design documentation https://cloud.google.com/apis/design/ as design guideline, but I am not sure if it covers the aspect of TTL.