I have some methods in my code that essentially hide/show some Views, like showTitleHideBody()
, showBodyHideTitle()
, etc. They just change their Views' (tvTitle
, tvBody
) visibility.
Initially those Views were globals, but as it is not good practice, I moved the Views to OnCreateView
and added parameters to those methods that need them. Now, I call them like showTitleHideBody(tvTitle, tvBody)
.
But whenever I need to call some method it'll always be doThisDoThatDoThose(tvThis, btnThat, smthThose)
. Methods like these are called multiple times in my code and I'm always passing the same parameters.
So, is there any better way to do this than repeatedly passing the same ~2-3 parameters everytime I call some method? Or is that ok and the recommended way, and trying to "fix" this would just further complicate things?