-4

I have a configuration problem, from this code, https://github.com/plum-umd/java-sketch.

Here, I must set $JAVA_HOME, because:

"One possible issue you may encounter while building sketch-frontend is the inconsistent Java version in Maven, e.g., Maven refers to Java 1.6 while the main Java you're using is 1.7 or higher. In that case, set up $JAVA_HOME properly."

I should setup $JAVA_HOME, but to what value?

Here is my JAVA,

$ java -version

openjdk version "14.0.2" 2020-07-14 OpenJDK Runtime Environment (build 14.0.2+12-Ubuntu-120.04) OpenJDK 64-Bit Server VM (build 14.0.2+12-Ubuntu-120.04, mixed mode, sharing)

The current error when executing the program is:

$./sketch SKETCH version 1.7.0 your java version is out of date. Version 1.6 required

What value should $JAVA_HOME take, in this case?

-1

The assumption here is that you have multiple java versions installed. You should set up JAVA_HOME to point to a Java 1.6 (= Java 6) installation. The version you have is Java 14.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.