What is the best naming pattern for a component that updates the state of an object?
Suppose I am writing a game. This game has an object called GameState. The GameState merely holds the data relevant to the game and performs no actions. Rather, GameState is updated by a separate component.
I have a few ideas:
- GameStateUpdater: very explicit and precise, but seems awkward to say
- GameStateProcessor: rolls off the tongue a little easier, but I don't know that 'process' is the correct verb, since it implies a one-way transformation from an unprocessed state to a processed state
- GameStateManager: seems overused and vague
I would like to hear any other ideas. Maybe Updater is good enough and I'm just overthinking it?