I have a Java class that handles import and export of data. It started out as a simple
private void export() {
}
private void import() {
}
Of course, I wrote the export first, committed it, and then went on to write the import. But import is a keyword in Java - I can't use that as a function name. So I go back and rename both methods. I usually end up with
private void doExport() {
}
private void doImport() {
}
which is both ugly and feels contrived. What do you think of these names? Got any better suggestions?
Note: I'm asking now, because it's now happened thrice and that keyword is getting quite annoying.