No. Dont make functions with names very similar to built-in functions, but which actually does the opposite. It may seem intuitive to you, but is going to be very confusing to other developers, and even to yourself some time in the future when you have more experience.
But it is totally fine to wrap a built-in function in another function with a more specific name for your purpose, eg.
cap(x, limit) as has been suggested.