1

What you are referring to is colloquially called Dependency Hell and it has been a known problem since software became a thing. The most IMO common solution to this is to use semantic versioning along with backwards compatibility. The basic idea is that all packages, including yours, define their dependencies not exactly but as "this or higher version". ...


Only top voted, non community-wiki answers of a minimum length are eligible