3

Is this a bad practice?

const int sId(int const id);

// true/false it doesn't matter
template<bool i>
const int sId(int const id) {
    return this->id = id;
}


const int MCard::sId(int const id){
    MCard card = *this;

    this->id = id;

    this->onChange.fire(EventArgs<MCard&, MCard&>(*this, card));

    return this->id;
}


myCard.sId(9);

myCard.sId<true>(8);

As you can see, my goal is to be able to have an alternative behaviour for sId.
I know I could use a second parameter to the function and use a if, but this feels more fun (imo) and might prevent branch prediction (I'm no expert in that field).

So, is it a valid practice, and/or is there a better approach?

2
  • 5
    This would warrant a WTF moment in code review for me. I see what you're going for, and I sympathize your cause. That said, don't do it.
    – Neil
    Commented Jun 9, 2014 at 10:26
  • Why not just two functions: sId() and sIdTrue() Commented Jun 10, 2014 at 3:50

1 Answer 1

10

Actually, it seems you are just overcomplicating things, which might obfuscate your code. This

sId

and this

sId<true>

are just two different functions. And the standard way of implementing two different functions (with the same signature) is simply to use two different function names, without the template hoodoo voodoo, like sIdWithoutEvent and sId (assumed the latter one is calling the event).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.