This is quite a subjective question, and it might also depend on what kind of language you are using.
It really depends on what you have put in your statement1 and statement2.
The most important part of any question like this is readability. Does one approach look better? Remove duplicate code? Reduce code bloat?
There is also a matter of scope. If you have a variable such as:
var variable;
if (condition1)
{
variable = someValue;
}
if (condition2)
{
function(variable);
}
Then it might be better nested.
if (condition1)
{
var variable = someValue;
if (condition2)
{
function(variable);
}
}
Then there is a matter of maintainability.
If the statements are unrelated (they share no local variables and neither conditions or statements depend on the other), then separating them would be more readability and quicker to edit. You won't have to consider the previous condition when imagining the code's workflow.
You might want to consider separating them into functions, if they are completely separate.
if ( condition1 )
block in your second example to another method/function.